SharePoint Reporting Services Subscription Management using PS Scripting
One of the more tedious things to manage in SharePoint are the SQL Reporting Services reports. Going through item by item to configure the data sources, parameters and shared schedule processing can...
View ArticleDisplay Metadata Tags in SharePoint Search Core Results
SharePoint 2010 and onwards has the excellent feature of being able to tag content with customizable metadata. This great for using the refining options that are built into the framework. For...
View ArticleLocking Down Search for a Site (Part 2 – SP2013, SP2016, SP2019)
If you want to achieve the functionality I outlined in “Part 1” using SharePoint 2013 UI, or higher (SP 2016, 2019), you are going to need to go through a different process, as Microsoft deprecated...
View ArticleLocking Down Search for a Site (Part 1 – SP2010, SP2013*)
One of the SharePoint features that does not always work as expected is the “Search This Site” component. If one is doing a search using this option, the results page can sometimes get confusing very...
View ArticleSharePoint Migration Tool Error – 0x01710009
When using the SharePoint Migration Tool to move to 365, you may encounter some cryptic errors in the tool’s error reports, such as the following: (In this example I was trying to move a discussion...
View ArticleErrors When Adding SP2013 Navigation in SP2010 UI Mode
There is an rather obscure error that can occur when working with “Audiences” and groups in SharePoint 2010 mode within SharePoint 2013. The problem can surface when trying to create list items based...
View ArticleDisable Install Silverlight Prompt in SharePoint 2013
If you have users that are still using IE to visit your SharePoint 2013 sites, they may encounter an IE message telling them they should install the latest version of Silverlight (which is quite dead)....
View ArticleRemove a SharePoint Search Server from the Search Service Application
Occasionally there will be instances where you need to remove a server from the Search Service Application, if you have multiple search servers set up in the farm. To do so, especially if the server is...
View ArticleSharePoint Search Box Not Firing When Enter Pressed in IE
Ran into an issue in SP2013/SP2010 where the Enter/Return key would default to other page elements instead of taking the keywords and conducting the search if the Enter key was pressed. So for example,...
View ArticleFiltering SharePoint Search by Calendar Dates
SharePoint, out of the box does not support filtering calendar dates. The reason for this is that to search, they are set up as strings, thus running a comparision is not achievable. Example: Let’s...
View ArticleSetting up Office Web Apps Server for SharePoint & Publishing via ADFS WAP
1. Create a new vanity DNS entry for Office Web Apps that points to the ADFS WAP for public consumption (ie. officewebapps.contoso.com -> 10.92.92.100) 2. Download and run install software [i.e....
View ArticleGet Web Sites Owners Listing (Powershell to Text File)
I created this script to gather a listing of web site owners within a Site Collection. It has been set to only gather the first tier of sites. If you wish to go deeper, change the comparision. if...
View ArticleCan not convert claims identity to windows token. This may be due to user not...
Can not convert claims identity to windows token. This may be due to user not logging in using windows credentials. If you receive this message when trying to run a report after upgrading your...
View ArticleProvision Search Service On Any SharePoint Server (with no migration)
This is based on scripts at http://www.harbar.net/articles/sp2013mt.aspx. I have modified the original script because if you are provisioning this on a server that is not the Central Admin server, you...
View ArticleAutomatically Filing SharePoint Documents After Timespan
1) Set up a Document Library that will house the “temporary” documents (ie. the documents that you plan on having automatically filed). For instance “New Documents.” 2) Then set up a separate “Custom”...
View ArticleHow To Create A “Private” SharePoint Discussion Board
One of the requests I hear most from users is for the ability to create a private discussion board on their site. They have a general user base, but want to lock down a particular SharePoint...
View ArticleUnable To Remove Server From Farm / cacheHostInfo is null
If you run into issues trying to remove a server from your SharePoint 2013 farm, particularly where you think the AppFabric install on that server is corruped/unfixable and you want to reinstall. Try...
View ArticleThere are no products affected by this package installed on this system /...
When running a cumulative update to the SharePoint 2013 farm servers, I encountered an error message in the Configuration Wizard. It stated that there were missing packages on my non-central admin...
View ArticleSharePoint 2013 Re-installation – Prerequisite Installer Continuously Restarts
If you are attempting to re-install SharePoint on a server, after you have run the uninstall option for both SharePoint 2013 and Appfabric 1.1, you may encounter an issue when running the Prerequisite...
View ArticleCreating a Classic Authentication Web Application in SharePoint 2013
To create a new web application using classic mode, run the following: New-SPWebApplication -Name "Portal" -ApplicationPool "Classic App Pool" -AuthenticationMethod "Kerberos"...
View Article